Fly.io Upstash Redis service distruption (FRA region)

Incident Report for Upstash Status

Resolved

The incident has been resolved. We are working with Fly team on RCA.
Posted May 11, 2026 - 18:22 UTC

Update

We are working with Fly team to investigate the root cause.
Posted May 11, 2026 - 17:19 UTC

Update

We are continuing to investigate the issue.
Posted May 11, 2026 - 15:07 UTC

Investigating

Some databases may experience increased latency or timeouts in Fly.io’s FRA region.
Posted May 11, 2026 - 15:05 UTC