Performance degradation on QStash

Incident Report for Upstash Status

Postmortem

On 09:43 UTC, QStash experienced degraded service when a high number of requests to a specific domain were throttled, resulting in timeouts during an unexpected phase of the TCP connection establishment. These requests and resulting retries triggered excessive consumption of network resources and negatively impacted all users. We have added more resources to QStash as a quick remediation and as for the resolution, we have improved the timeout mechanism to detect and fail-faster in such cases.

Posted 14 days ago. Mar 12, 2025 - 12:36 UTC

Resolved

This incident has been resolved.
Posted 14 days ago. Mar 12, 2025 - 10:16 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted 14 days ago. Mar 12, 2025 - 10:08 UTC

Investigating

We are currently investigating this issue.
Posted 14 days ago. Mar 12, 2025 - 09:43 UTC
This incident affected: QStash.