Upstash Redis Partial Service Disruption

Incident Report for Upstash Status

Resolved

This incident has been resolved, we will publish RCA soon.
Posted Jun 25, 2026 - 16:36 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 25, 2026 - 15:31 UTC

Investigating

We are currently experiencing a partial service disruption affecting Upstash Redis in the following regions:

* eu-central-1
* us-east-1
* us-west-1

Our team is investigating the issue and working to restore full service as soon as possible. We will share updates as more information becomes available.
Posted Jun 25, 2026 - 15:23 UTC
This incident affected: Redis Global (N. Virginia, USA (us-east-1), N. California, USA (us-west-1), Frankfurt, Germany (eu-central-1)).