Earlier today, unexpected load on our proxies caused intermittent connection issues for Upstash Redis in the following regions: us-east-1, us-west-1, ap-southeast-2, and ap-south-1.
During this period, some clients may have seen connection timeouts or elevated error rates when reaching their databases. Our team identified the issue quickly and applied workarounds to relieve pressure on the affected proxies. Connection health has since been restored and we've been monitoring the regions to confirm everything is stable. All systems are now operating normally.
We appreciate your patience and apologize for any disruption this may have caused.
Posted May 14, 2026 - 17:31 UTC
Monitoring
A fix has been implemented and we are monitoring.
Posted May 14, 2026 - 16:00 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted May 14, 2026 - 15:49 UTC
Monitoring
We identified intermittent connection issues affecting some regions. Fix is being deployed. We'll update the list of affected regions shortly.
Posted May 14, 2026 - 15:47 UTC
This incident affected: Redis Global (N. Virginia, USA (us-east-1), N. California, USA (us-west-1), Sydney, Australia (ap-southeast-2), Mumbai, India (ap-south-1)).