Fly.io infrastructure disruption affecting some Upstash Redis databases on Fly.io DFW Region

Incident Report for Upstash Status

Resolved

This incident has been resolved.
Posted Jul 22, 2026 - 10:05 UTC

Monitoring

The affected Fly.io-hosted machines recovered at 08:48 UTC, and service availability has been restored. We are monitoring the systems to confirm continued stability.
Posted Jul 22, 2026 - 09:01 UTC

Identified

We are investigating connectivity issues affecting a subset of Redis databases hosted on Fly.io. The issue is related to an ongoing Fly.io infrastructure disruption in the DFW region (https://status.flyio.net/incidents/n4z2my6qw4sb). We are working to restore availability and will provide updates soon.
Posted Jul 22, 2026 - 08:50 UTC