Fly.io Upstash Redis – iad Region Elevated Latency and Temporary Read-Only State

Incident Report for Upstash Status

Resolved

Replication complete, incident resolved.
Posted Apr 02, 2026 - 19:53 UTC

Identified

Servers in the iad region experienced unexpected disk load, resulting in elevated latencies and a temporary read-only state. We are migrating replicas to new instances to mitigate the issue and expect to have it fully resolved shortly.
Posted Apr 02, 2026 - 18:45 UTC