Fly.io - Upstash Vector service disruption on IAD region

Incident Report for Upstash Status

Resolved

This incident has been resolved.
Posted Jun 04, 2026 - 14:09 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 04, 2026 - 12:56 UTC

Investigating

We are currently experiencing a service disruption affecting Upstash Vector in the IAD region.

Initial investigation indicates that the issue is related to a Fly.io networking/routing problem impacting connectivity in the region. The Fly.io team is actively investigating the underlying cause.

We will continue to monitor the situation and provide updates as more information becomes available.
Posted Jun 04, 2026 - 10:10 UTC