Intermittent slowness in Vector US-EAST-1 region

Incident Report for Upstash Status

Resolved

The issue affecting some Upstash Vector indexes in the US-EAST-1 region has been resolved.

Our team investigated the incident and identified the conditions that were contributing to elevated memory pressure on the affected servers. We mitigated those conditions by reducing memory utilization on the impacted nodes, rebalancing affected workloads where needed, and increasing available headroom capacity across the region.

All affected indexes should now be operating normally, and based on the mitigations applied, we do not expect this issue to recur. We apologize for any inconvenience this may have caused.
Posted May 30, 2026 - 07:51 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 29, 2026 - 23:44 UTC

Investigating

Some Upstash Vector indexes in the US-EAST-1 region may be experiencing intermittent slowness. Initial investigation indicates this may be related to memory pressure on the affected servers.

Our team is actively investigating the root cause and working to restore normal performance. We will provide updates as soon as more information is available.
Posted May 29, 2026 - 20:18 UTC
This incident affected: Vector (AWS - US-EAST-1).