QStash: Degraded performance

Incident Report for Upstash Status

Postmortem

An internal cleanup task for QStash events, coinciding with disc layer compaction task has caused performance degradation to some users.

Mitigation: Team has mitigated the event by pausing some of these tasks and monitored the status for a while.

Fixes: Improvements are being applied to these tasks to use resources more gracefully. Disk resources are increased to be able to handle a bigger burst of load.

Posted Apr 18, 2025 - 13:23 UTC

Resolved

This incident has been resolved.
Posted Apr 18, 2025 - 13:18 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 18, 2025 - 12:46 UTC

Update

We are continuing to investigate this issue.
Posted Apr 18, 2025 - 12:36 UTC

Investigating

We are currently investigating this issue.
Posted Apr 18, 2025 - 12:36 UTC
This incident affected: QStash.