On May 12th and 13th at various times, a subset of Upstash Redis instances on Fly.io experienced intermittent hangs and elevated error rates. The Redis process would stall inside a logging syscall — alive but not making progress — which made the issue hard to spot from our usual telemetry. After investigating with Fly's team, we identified the root cause as a bad interaction between a recent guest kernel update on Fly's newer machines and an upstream Cloud Hypervisor bug (cloud-hypervisor#7672) affecting log writes from inside the VM. We mitigated by disabling the affected logging paths, and Fly has since rolled out a hypervisor-side patch, fully resolving the issue. No data was lost. Sorry for the disruption.
Posted May 15, 2026 - 12:48 UTC
Resolved
This incident has been resolved.
Posted May 12, 2026 - 13:48 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 12, 2026 - 12:05 UTC
Identified
The issue has been identified and the fix is being implemented.
Posted May 12, 2026 - 10:50 UTC
Investigating
Some regions are experiencing connectivity issues due to an ongoing network problem. We are currently investigating